1

I'm managing a SeaFile instance where I'm encountering a weird set of log messages on MariaDB start. Here is what systemctl status mysql spits out:

systemctl status

I don't know what that is. MariaDB says Upgrade failed. I did not ask for any upgrades. MariaDB says Access denied for user root@localhost. I can run sudo mysql -u root which results in a welcome message, but the console input line starts with MariaDB [(none)]> I also do not know what that is or means.

I can't find any information on these error logs, especially about the Upgrade message.

UPDATE: I have followed instructions from here. Now the server doesn't start at all, and falls over with this error.

3
  • Welcome, it would be so much better if you posted text information as text instead of an image. Commented Jan 21, 2023 at 1:58
  • Perhaps you had the wrong password for MariaDB's :root: user?
    – Rick James
    Commented Jan 21, 2023 at 3:27
  • No, the error clarifies that the login attempt was PASSWORD: NO. Meaning the attempt was not by using password but by some other means. I don't really understand it and can't find any documentation on this.
    – masiton
    Commented Jan 21, 2023 at 14:00

1 Answer 1

1

In my case, I just ran into this issue after what turned out to be 2 unfortunate events.

I did a minor MariaDB upgrade, which restarted the server. Unfortunately, the server crashed during shutdown, and the upgrade script, which on OpenSUSE is ExecStartPre=/usr/lib/mysql/mysql-systemd-helper upgrade tried to run mysql_upgrade which in turn crashed because some of the tables were corrupted and Innodb recovery hasn't run yet. Because of this ExecStartPre step failure, the start script never got to starting the actual Mariadb (ExecStart=/usr/lib/mysql/mysql-systemd-helper start).

What I did to fix it:

  1. Start MariaDB directly, bypassing the upgrade step: /usr/lib/mysql/mysql-systemd-helper start. The server started fine and performed a recovery step:
2023-05-22 11:41:25 0 [Note] mysqld: Aria engine: starting recovery
recovered pages: 0% 10% 20% 38% 50% 60% 70% 80% 90% 100% (0.0 seconds); tables to flush: 4 3 2 1 0
 (0.0 seconds);
2023-05-22 11:41:25 0 [Note] mysqld: Aria engine: recovery done
  1. At this point, mysql_upgrade or /usr/lib/mysql/mysql-systemd-helper upgrade complete OK and don't crash.

  2. Done. I checked with rcmysql restart and the server restarted OK. The issue is now solved.

I think the MariaDB/MySQL teams can definitely optimize for this case and try to trigger an automatic repair during upgrade if it's needed.

Hope this helps someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.