1

I have opened a CMD with Administrator credentials and opened "setup.bat" from there. But the installation gets stuck at the step "Launching installer". PFB Screenshot. As per the log It's stuck at "INFO: Checking whether the IP address of the localhost could be determined..."

I waited for 30-45 minutes before killing the process from task manager and restart PC and retry installation. (Only potential room for issue/conflict I sense is that I had installed Oracle 32-bit client (12c), though uninstalled it using de-install procedure before proceeding with 19c 64-bit installation)

Details: OS: Windows 11 Oracle DB version: 19c 64-bit

enter image description here

For the record I have tried below things suggested in community and Stackoverflow

  1. Disabling IpV6
  2. Disabling all adapters
  3. Killing all services relevant to Oracle
  4. Cleaning Installation folder in "Temp" directory Under "C:\Users<user>\AppData\Local\Temp
  5. Cleaning all files in "Oracle Inventory" under "Program files"
  6. Restarting system multiple times after the above steps
  7. Copying files into "C:\ins" folder so that file path is shorter
  8. Flushing the DNS using CMD/
4
  • The installer should generate a log file. Are there any clues there?
    – pmdba
    Jan 27, 2023 at 20:08
  • @pmdba, "INFO: Checking whether the IP address of the localhost could be determined..." Nothing after that from 1 hour. I've already tried this stackoverflow.com/questions/57547692/… Jan 27, 2023 at 20:32
  • I have already tried 8 different suggestions (edited question to update them) Jan 27, 2023 at 22:16
  • So far I didn't get answer for this, I ended up with installing 12C. Though it's outdated, atleast for the need of mine, it was ok to install. Feb 8, 2023 at 10:29

2 Answers 2

1

Faced similar issue in Windows 11 22H2. Was able to resolve with recommendations from Doc ID 2892311.1 and other places combined.

  1. The status of Windows Service Server and WorkStation must be Running
  2. The network components Client for Microsoft Network and File and Printer Sharing for Microsoft Networks must be checked in the "Ethernet" properties

And added few arguments while launching installer:

setup.exe -ignorePrereq -J"-Doracle.install.db.validate.supportedOSCheck=false"
0

Did you try to comment the entry for the RDBMS on the /etc/oratab, if there was one?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.