2

Getting Gossip error when trying to setup 3 node cluster.

  1. Node-1: Private IP: 10.10.0.1 Public IP: public_ip_1
  2. Node-2: Private IP: 10.10.0.2 Public IP: public_ip_2
  3. Node-3: Private IP: 10.10.0.3 Public IP: public_ip_3

Here you go my cassandra.yaml

seeds: '10.10.0.1' 
listen_address: 10.10.0.1
broadcast_address: public_ip_1
start_native_transport: true
native_transport_address: public_ip_1

Error

ERROR [DSE main thread] 2023-02-16 09:38:09,271  CassandraDaemon.java:938 - Exception encountered during startup
java.lang.RuntimeException: Unable to gossip with any peers

Node get shut down

1 Answer 1

-1

For nodes to be able to be able to gossip with each other, there needs to be network connectivity between nodes on TCP port 7000 (7001 for SSL) in both directions.

If the ports are blocked or if there is no network route then gossip won't work.

If the servers have the wrong time, this will prevent gossip from working since Cassandra uses a server's local time when validating the gossip information from another node. If a server's time is wrong, the gossip information will be rejected as invalid.

Additionally, incorrect permissions on the commitlog/ directory will block memtable flushes which also stops gossip from working.

For more information, see Why would a new node be "Unable to gossip with other peers"?. Cheers!

2
  • If we make native_transport_address=0.0.0.0 and native_transport_broadcast_address: public_ip cluster spin up successfully. There is no issues which show there are no constraints of network connectivity or any incorrect permissions on the commit log. Feb 17, 2023 at 21:28
  • On the production cluster when adding broadcast_address: public_ip node did not join the cluster with the error 'Unable to gossip with any peers'. with the cluster setting seeds: '10.10.0.1', listen_address: 10.10.0.1 , native_transport_address: 0.0.0.0, native_transport_broadcast_address: public ip. The same setting worked perfectly on a brand-new cluster. Feb 17, 2023 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.