I tried to build a 6 nodes cassandra cluster with 2 DCs on AWS. I created EC2 with t2.micro on public subnet with public IP. The OS is Ubuntu 22.04. After install, I changed the listen_address to private IP and seeds set the same IP. I set the endpoint_snitch to Ec2Snitch and cassandra instance was running and when I issued nodwtool status I got below error:

root@ip-10-0-0-119:/etc/cassandra# nodetool status
nodetool: Failed to connect to '' - ConnectException: 'Connection refused'.

I tried other snitch such as GossipingPropertyFileSnitch and SimpleSnitch. no help.

I checked google for multiple posts and none of them helps. please advise if there is suggestion.

1 Answer 1


Provided you didn't modify the JMX port, the most likely causes of the Connection refused exception are:

  1. Cassandra is not running.
  2. JMX port 7199 is bound to a different IP.

Point (2) is only a possibility if you've modified the configuration in conf/cassandra.yaml in which case you need to connect with nodetool using the values (IP, port) you set yourself.

Otherwise, it is almost always because Cassandra is not running so you need to review the Cassandra system.log for clues. In my experience, it is usually a misconfigured cassandra.yaml. Cheers!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.