Consistency error in DB. 
1 page from sys.syscolpars table is missing.

There is no any impact but the thing is can't able to upgrade the DB from 2008 to higher version. Backup restore fails. Old good backups are not available.

  • As this is a sys schema table so needed DAC connection to query it. But even through DAC connection, not able to do 'DBCC repaid rebuild' or Drop-index-rebuild index, as its not allowing ay DML activity.
  • Tried to take a backup into new table with select * into (hoping i will rename & keep new table and drop original one) but can't do this. Sys schema perhaps, not allowing to create new table.
  • I tried to script out the whole DB to create a new db from it, but application sprocs are encrypted. I can decrypt sprocs individually using some free utilities available online ( haven't tried yet), but thats not I want basically.

I want the whole script in a single, composite way, at one place. What is the way forward?



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.