The mongodb server on my ubuntu Virtual Private Server Crashes on regular basis.

mongod.service - MongoDB Database Server
     Loaded: loaded (/lib/systemd/system/mongod.service; enabled; vendor preset: enabled)
     Active: failed (Result: signal) since Sun 2023-03-12 19:10:28 UTC; 6min ago
       Docs: https://docs.mongodb.org/manual
    Process: 26209 ExecStart=/usr/bin/mongod --config /etc/mongod.conf (code=killed, signal=KILL)
   Main PID: 26209 (code=killed, signal=KILL)

Mar 12 18:36:06 TruckersHub systemd[1]: Started MongoDB Database Server.
Mar 12 19:10:28 TruckersHub systemd[1]: mongod.service: Main process exited, code=killed, status=9/KILL
Mar 12 19:10:28 TruckersHub systemd[1]: mongod.service: Failed with result 'signal'.

I tried a lot of solution present on internet but none worked.

  • 1
    Have a look at the logfile, typically at /var/log/mongodb/mongod.log Mar 12 at 19:26
  • Please include example of how you are attempting to start the process. Based on what is presented, it appears you are trying to run a systemd script. What user are you using to start the process. When posting it is helpful to include all the details. Mar 12 at 19:51
  • The exit status indicates it was terminated by SIGKILL. Do the system or journal logs indicate what sent that signal?
    – Joe
    Mar 13 at 2:38

1 Answer 1


This is normal in the situation that the mongod has been started with systemd, forked backgound but there is no PID file present. Process is killed after few seconds after start. So, check that mongod is allowed to create PID file and it's location is stated at mongod.service -file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.