0

I need to backup sql db around 39GB. When I'm doing backup without single-transaction option - everything is ok, I got full dump of my DB. But when I try to add single-transaction option, I got incomplete dump, last 20 tables always missing. They all got InnoDB engine. I even try to increase mac_packet_size to 512M but it did not help.

I'm using Ubuntu 20.04 and Mysql version is:

mysql Ver 8.0.32-0ubuntu0.20.04.2 for Linux on x86_64 ((Ubuntu))

I notice this error during backup:

Table definition has changed, please retry transaction when dumping table

1
  • Are you backing up from a slave/replica database? If so, simply stop replication for the duration of the backup (if possible).
    – IGGt
    May 5, 2023 at 9:28

1 Answer 1

1

Are you getting "Table definition has changed, please retry transaction"

Try using --order-by-size option which was motivated by this error.

Ref: mariadb-dump kb page.

2
  • Got error, no such option.
    – zeronight
    Apr 28, 2023 at 18:47
  • Ah, using MySQL and not MariaDB.
    – danblack
    Apr 29, 2023 at 5:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.