0

Installing MySQL Server 8.0.33 on a Ubuntu 20.04 server with FIPS enabled results in an error. This error doesn't occur when installing the previous MySQL Server version (8.0.32). The error also doesn't occur when the server is not running with FIPS enabled.

During the installation, it returns the following error message:

2023-05-15T18:39:17.482061Z 0 [ERROR] [MY-011065] [Server] Unable to determine if daemon is running: No such file or directory (rc=0).
2023-05-15T18:39:17.482074Z 0 [ERROR] [MY-010946] [Server] Failed to start mysqld daemon. Check mysqld error log.

I tried this on a fresh installation of Ubuntu Server 20.04 to be sure it wasn't some other package or setting that was causing the error.

Here are my steps:

  • Installed Ubuntu 20.04 on VM VirtualBox 7.0
  • Ran $ sudo apt update
  • Ran $ sudo apt upgrade
  • Removed default actions from GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub (These were preventing FIPS from enabling properly).
  • Ran $ sudo update-grub to apply changes.
  • Installed Ubuntu Advantage with $ sudo pro attach <UA Token>
  • Rebooted Server
  • Ran $ sudo pro enable fips
  • Rebooted Server again
  • Ran $ sudo apt install mysql-server (This is where failure occurs).

1 Answer 1

1

This issue was occurring because FIPS was enabled on the Operating System using Ubuntu Pro, but was not enabled within MySQL.

To enable FIPS, go to /etc/mysql/my.cnf and add the following line:

[mysqld]
ssl_fips_mode = ON

Restart MySQL:

sudo systemctl restart mysql

And then run another upgrade to fix the MySQL packages that didn't fully install:

sudo apt upgrade

I'm still not sure why this issue didn't show up until version 8.0.33, but this is what fixed it for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.