3

I am having serious problems getting pgAdmin 4 to load. I'm running on Windows 10. Please see attached screenshot. I have naturally tried to troubleshoot this problem myself. I have followed instructions from a google search to change the .js content type to have the value text/javascript in the registry editor and then closed pgadmin and its servers in task manager. Annoyingly I still get the same error message.

I previously tried to install postgreSQL about 2 months ago and then deleted it. Could it be that I have somehow caused a problem. I uninstalled postgreSQL by right clicking on it and clicking uninstall.

What else coud I try to troubleshoot this problem? Thank you

enter image description here

The error message

1
  • Do yourself a favor and use psql. It works reliably and is much more powerful. May 24, 2023 at 18:02

1 Answer 1

2

I installed pgAdmin 4 directly from an exe file and that seems to have worked. I don't understand why it wouldn't install properly as part of the postgresq package but problem solved. :)

Edit : The link to working pgAdmin 4 is https://www.pgadmin.org/download/pgadmin-4-windows/

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.