0

I've installed PGadmin4 on my Ubuntu 22.04 system, with this repository :

https://ftp.postgresql.org/pub/pgadmin/pgadmin4/apt/$(lsb_release -cs) pgadmin4 main

PGAdmin4 runs, but if I want to see data from my postgreSQL tables (right-click on a table, then "View/Edit data"), or if I try a "select" query, PGadmin4 returns the error :

"missing "from" clause entry for the table « rel » LINE 8: ...ER JOIN pg_catalog.pg_constraint con ON con.conrelid=rel.oid"

So I don't know which relation is missing, and why. My databases are correct : I'm using them with DBeaver without any problem. And my colleagues can access to them with PGAdmin4 for Windows without worries.

How can I see the whole underlying query?

Why Pgadmin can't view data from correct databases?

Do you have any clues?

1 Answer 1

1

Check your database server version. Newest PgAdmin 7.version does not support PostgreSQL server 10. I had the same error on Postgres 10, and installing PgAdmin 6, everything worked fine.

1
  • Thank you very much @artis, my problem has been solved using "apt install pgadmin-server=6.21" and "apt install pgadmin-desktop=6.21".
    – V Damoy
    Jul 4, 2023 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.