0

This is a strange issue. I have a user (let's call them A), that needs to 'refresh data' on an Excel spreadsheet. The user is able to log into Excel using their domain credentials. They can input and save information to the spreadsheets.

When A hits refresh data on their spreadsheets, this error occurs.

A connection was successfully established with the server, but then an error occurred during the login process. (provider: SSL Provider, error: 0 - The certificate chain was issued by an authority that is not trusted.)

I've also tried having the user login via SSMS, here is the error message.

===================================

Cannot connect to <server name>.

===================================

Login failed for user 'A'. (Framework Microsoft SqlClient Data Provider)

------------------------------

For help, click: https://docs.microsoft.com/sql/relational-databases/errors-events/mssqlserver-18456-database-engine-error

------------------------------

Server Name: <server name>

Error Number: 18456

Severity: 14

State: 1

Line Number: 65536

------------------------------

Program Location:

   at Microsoft.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction)

   at Microsoft.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose)

   at Microsoft.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady)

   at Microsoft.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)

   at Microsoft.Data.SqlClient.SqlInternalConnectionTds.CompleteLogin(Boolean enlistOK)

   at Microsoft.Data.SqlClient.SqlInternalConnectionTds.AttemptOneLogin(ServerInfo serverInfo, String newPassword, SecureString newSecurePassword, Boolean ignoreSniOpenTimeout, TimeoutTimer timeout, Boolean withFailover, Boolean isFirstTransparentAtte

MSSQLSERVER_18456 - SQL Server

A connection attempt is rejected due to a failure with a bad password or username in SQL Server. See an explanation of the error and possible resolutions.

We have user B, who is in the same AD group as A. Also is in the same SQL group as A and he is able to 'refresh data' on the excel spreadsheet with no problem. According to our sysadmin, user A has more privilege than user B.

With user A, I've tried resetting password, force reset, setting up his own user login to the SQL Server db, read through the tech articles, and set connection properties to "Trust Server Certificate".

I myself and our sys admin are not sure what is going on.

I'm also not a DBA, so looking for some ideas I can try to fix this issue.

1
  • So user A tried to connect to gissqlprod01 with SQL server or Windows authentication? Do you use connection encryption? Can you check SQL server logs regarding the login failed to get actual reason (State: 1 means you do not have permission to know)?
    – SergeyA
    Aug 28, 2023 at 19:48

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.