0

We are replacing an old VM which was configured with reporting services 2016. The Web Service and Web Portal URL's were configured for both a "public" URL which looks nicer as well as a URL that reflects the name of the VM SSRS is installed on which is typically only used by our developers. When I went to configure our new VM, the only option I had for the connection string was to use the certificate of the machine, meaning the URL is not pretty and most importantly will require many clients to update their bookmarks. We are trying to avoid this by also configuring the "public" URL to be the same as the old server but I don't seem to have an option to make a custom URL.

Ex.

Old Server has: https:\\vm_name.domain.com && https:\\custom_url_here.domain.com

New Server has: https:\\vm_name.domain.com - I cannot for the life of me get the custom URL configured in the reporting services configuration manager

Things I have tried:

  • Editing the rsreportserver.config file to both match the old server or at the very least have the URL connection I need added (breaks both connections)
  • Manually exporting the old servers HTTP registry keys for the custom URL only in tandem with editing the config file (strangely allows the custom URL to work, but the VM URL then breaks despite the registry entry for the VM URL not changing - I did not export that value from the old server as obviously the new server has a different name value)

As an FYI - Each time I have tried something I have restarted the services accordingly and seen the changes reflected in SSRS.

When I edit the config file (Microsoft says this won't work fully but doesn't provide another option, hence why I tried the reg keys at the same time), the "custom URL" actually starts working, but then the regular URL breaks. Why is it so difficult to just define my own URL? Do I need to generate a certificate for that custom URL and add it to the new VM in the hopes Reporting Services Configuration Manager finds that? When I hit the certificate drop down in SSRS COnfig Manager the only option I have is for the server name hence why I was thinking generating a custom certificate with the name I want might get around this.

enter image description here

Any suggestions??? I'm at a loss as to how the old server had a custom URL name. I also did not find any certificates on that old VM for the custom URL so I really don't know how it could have been created....

1 Answer 1

0

I was able to resolve this issue, although it was not as straightforward as I thought, in part due to my lack of understanding in how our VIP software/redirects work.

Long story short, the solution was to configure a wildcard certificate for our domain and add it to the servers. With that wildcard certificate added, we then removed the verbose URL connection in Report Services Config Manager and added a "generic" URL using the wildcard certificate. The new URL ended up looking like this:

Obviously you would hit the certificate drop down and select the wildcard certificate you generated. The generated URL won't be hyperlinked so I think this is just allowing/redirecting any 443 traffic. This allowed web access to the reporting server both with the custom URL name and our redirect URL.

I found this counterintuitive as it didn't match any of our old environments, but I am chalking that up to a discrepancy in Report Config Manager versions (we believe the old SQL Reporting Server was upgraded in-place from its old IIS setup which has more options for verbose URL headers).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.