I am getting in the Replication the subscription marked inactive and must be reinitialized. I tried to reinitialize not fixing the issue and found the following as well. I believe, I need to fix the DDL issue first then I need to reinitialize.

Transaction Replication error because of DDL changes one new column is added into Publisher and that is not not available in the subscriber.

Please assist me to fix this error and let me know if you need any further input.

  • "Please assist me to fix this error" - What is the exact error message? Adding columns to the tables in the Publisher are allowed and normally auto-replicate. If you set the the Article Properties to Truncate or Delete instead of Drop for that table, then you'll need to manually drop the table on the Subscriber side or manually add the same new column on the Subscriber side before pushing another Snapshot.
    – J.D.
    Nov 11 at 18:10
  • Thanks JD. The table are Drop existing and create 5 Errors I found in msrepl_errors: 1-Procedure or function sp_MSupd_dboTableXX has too many arguments specified. 2-Reader Thread has been shut down. 3-The row was not found at the Subscriber when applying the replicated (null) command for Table '(null)' with Primary Key(s): (null) 4-The subscription(s) have been marked inactive and must be reinitialized. NoSync subscriptions will need to be dropped and recreated. 5-if @@trancount > 0 rollback tran Nov 12 at 2:16
  • I can see the Error no 2. Publisher is having 1 row and subscriber is having 3 rows. I have tried to reinitialize it , still same errors, but sure it is moving/working or not but undistributed commands are changing. Nov 12 at 2:33
  • When you reinitialized, did you mark it to "use a new snapshot" too?
    – J.D.
    Nov 12 at 3:59
  • Yes, that is the only option it shown. Other option is not available. Nov 12 at 5:08

1 Answer 1


Just run this query in a new query window in the distribution server

USE distribution;

UPDATE [MSsubscriptions] SET [status] = 2;
  • I Have tried this, not working. Nov 14 at 15:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.