0

I am new to pgAdmin and i want to delete a row in a table directly inside pgAdmin. ChatGPT tells me I should be able to do this, either by a query

DELETE FROM table_name
WHERE column_name = 'desired_value'; 

(I've tried the code both with and without double hyphen around both coloumn_name and table_name)

...or by simply selecting and right-clicking on the row and pressing drop/delete. But nothing pops up when i right-click. I also can't edit the data. I does not allow me to make edits. I created the tables myself so I know i have the privileges (I also checked security to make sure I have the privileges).

The view looks like this

I keep getting the same error when trying to delete a row from the table:

ERROR: relation "dag_adressedar_241123" does not exist LINE 1: DELETE FROM "dag_adressedar_241123"

When i google it, it tells me I'm likely spelling the table name wrong, but I AM NOT. I just copy/paste the table name from its properties.

Finally I can note that a view is dependent on the table, but I don't know if that makes a difference. I tried deleting the view and it still won't let me delete or edit.

Can anyone tell me why it isn't letting me edit or delete rows?

Best regards

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.