0

I'm Altering some tables with a lot of NVARCHAR(MAX) column to NVARCHAR(4000) in Azure sql environment. I've already upscaled the database to 3000 DTU, and executed the script to alter.

I see that there are waits for : HADR_THROTTLE_LOG_RATE_MISMATCHE
for the replication. my replication database is 10DTU.

should i upscaled the replica database as well? what is the best practice for altering a large table of 20 million records to NVARCHAR(4000) from Nvarchar(MAX)?

enter image description here

1 Answer 1

1

The full name of the wait is HADR_THROTTLE_LOG_RATE_MISMATCHED_SLO and as you've already figured out, it has to do with the SLO chosen. Both sides of Geo Replicas should be the same SLO.

If your current global primary is 3000 DTU then your GeoDR secondary should also be the same. The link in the first paragraph has possible options:

Scale up to a higher service level in order to get the maximum log rate of a service tier, or switch to a different service tier. The Hyperscale service tier provides 100 MB/s log rate per database and 125 MB/s per elastic pool, regardless of chosen service level.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.