0

I installed barman on the same server as my production database. Perhaps not a good choice but it is that way. I use barman to make backups of the production database and of databases on other servers. Some of those databases are for development.

When there is a new version of PostgreSQL I first migrate the development databases to test the upgrade and some applications. When this is done, I do the production database as the last one.

During this time I want to continue to do backups of all of my databases. This is only possible if barman uses the new version. I thought that I could resolve this by installing the new version on the server that runs barman. I can see that after the installation that the psql used is from that version. But barman says that it uses the version from the production database.

Is there a way to tell barman which PostgreSQL version it should use?

1 Answer 1

-2

Isn't this driven by this environment variable? I would believe so.

enter image description here

2
  • 1
    Please do not answer with an image when text would work just fine.
    – mustaccio
    Feb 2 at 14:37
  • So you point to the Barman manual? I checked it and I will try it for the next upgrade to version 17. Strange that the PG_MAJOR_VERSION is not set to the one of the psql executable, and others for PostgreSQL, in the /usr/bin directory.
    – Marco
    Feb 2 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.