I wasn't paying attention when I was presented with the option to generate credentials for operating via SSL. Having gone through the whole process, I was advised to follow-up on installing credentials. Well, I didn't know what it was advising and I left the utility. Once I restarted the MySQL server, I was unable to log into mySQL Workbench as I had previously been able to do. This hasn't (so far) seemed to affect my logging into MySQL command line interface. So, that means I am able to tweak should I need to. Something tells me that there's settings in the user table identifying which clients can connect and from where. All of this is on one machine, where I run mySQL server and perform my client business. I don't think OS is affecting this -- my woes started once I used (what appeared to be) an automated setup to install SSL.

I found references online to a MySQL utility (mysql_ssl_rsa_setup) which is supposed to be for automating SSL setup. However, when I try this, I am presented with WARNING message: mysql_ssl_rsa_setup is deprecated and will be removed in a future version. Use the mysqld server instead. I'm running MySQL version 8.0.36. I don't know how to find the mysqld server version.

The specific message reported by my MySQL Workbench says: Your connection attempt failed for user 'root' to the MySQL server at localhost:3306. It goes on to give 4 things to try:

  1. Check that MySQL is running on address localhost. (CHECK!)
  2. Check that MySQL is reachable on port 3306. (CHECK!)
  3. Check the user root has rights to connect to localhost from your address. (CHECK! I can log in via the command line MySQL shell.)
  4. Make sure that you are both providing a password if needed and using the correct password for localhost connecting from the host address you're connecting from (Unsure about this one except to verify that I can log into the server using
mysql -u root -p

When I list the "variables like '%SSL%'" , I get a listing of about 30 items. "have_openssl" and "have_ssl" are both yes. "ssl_ca" is "ca.pem;" and "ssl_cert" is "server-cert.pem." Finally, "ssl_key" is "server-key.pem." "ssl_session_cache_mode" and "ssl_session_cache_timeout" are "ON" and "300" respectively. "ssl_fips_mode" is "OFF".

My question: How do I undo the damage done (i.e., disable ssl)?

1 Answer 1


All is restored. I simply added "skip_ssl" in the [mysqld] section of my configuration file. I restarted the server (not sure if it was required). And, bingo! I was able to access my server using MySQL Workbench. I removed the line, to test the results. And, it apparently does not need to remain there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.