0

I got an unmanaged VPS from Hostinger a week ago and am trying to host a few web sites on the server. I have to say here that I am quite new to Ubuntu 22.04 with FASTPANEL.

I have migrated the files and databases from the old server to this new one, except one sql file. The specifications of the old server are:

Old server

I tried to import this sql file of one of the web sites into phpMyAdmin without success. I believe it is not because of the size of the file. I had successfully imported a larger file of an almost identical site (in a different language). The specifications of the new server are:

New server

The error thrown by phpMyAdmin when importing is:

Error

Static analysis:

2 errors were found during analysis.

A symbol name was expected! (near ")" at position 206) At least one column definition was expected. (near ")" at position 206) SQL query: Copy

-- -------------------------------------------------------- -- -- Stand-in structure for view m6K_wsm_dateWiseBounceRate -- (See below for the actual view) -- CREATE TABLE m6K_wsm_dateWiseBounceRate ( );

MySQL said: Documentation

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 8

I believe there are no errors at the above specified lines.

I also tried to import it via Hostinger browser terminal:

cd /var/www/fastuser/data/www/en.beentee.net

mysql -u beentee -f -p enbeentee < mgls_enbeent.sql

The error thrown by the Hostinger browser terminal is:

Browser terminal error

I even tried to create an upload folder for phpMyAdmin with the following commands though I still do not know if the file can be imported this way:

sudo find / -type d  -name phpmyadmin

mkdir -p /usr/share/fastpanel2-phpmyadmin/vendor/phpmyadmin/upload
mkdir -p /usr/share/fastpanel2-phpmyadmin/vendor/phpmyadmin/save
chmod a+w /usr/share/fastpanel2-phpmyadmin/vendor/phpmyadmin/upload
chmod a+w /usr/share/fastpanel2-phpmyadmin/vendor/phpmyadmin/save

gedit /usr/share/fastpanel2-phpmyadmin/vendor/phpmyadmin/config.inc.php

cd /usr/share/fastpanel2-phpmyadmin/vendor/phpmyadmin
sudo nano config.inc.php

But the last two commands did not work:

$cfg['UploadDir'] = '/usr/share/fastpanel2-phpmyadmin/vendor/phpmyadmin/upload';

$cfg['SaveDir'] = '/usr/share/fastpanel2-phpmyadmin/vendor/phpmyadmin/save';

Please help me solve this problem.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.