I have installed a few versions of Oracle on my machine. I have tried 64 bit and 32 bit versions. I have installed 11G. I need Oracle 10G 32 bit.

Using the following guide I removed all versions of Oracle from my PC:

Uninstall all Oracle components using the Oracle Universal Installer (OUI).
Delete the HKEY_LOCAL_MACHINE/SOFTWARE/ORACLE key which contains registry entries for all Oracle products by using regedit.
Delete any references to Oracle services/components in the following registry location: HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/. Looks for key entries that starts with “Ora” which are obviously related to Oracle.
Reboot the workstation.
Delete the ORACLE_BASE directory. (i.e C:\Oracle)
Delete the C:\Program Files\Oracle directory.
Empty the temp directory.
Empty the recycle bin.


I then installed Oracle 10G 32bit.

When I go to connect in PL/SQL Developer I get:

ORA-12154: TNS:could not resolve the connect identifier specified. (http://i.stack.imgur.com/UGpwD.png)

I have set up my Oracle Home and added a value for tns_admin. My TNSNAMES.ORA file is in the directory referenced by tns_admin.

I think my Oracle is picking up the TNSNAMES.ORA file as the drop-down list for Database in populated in PL/SQL Developer.

The only options I see at the moment are:

  1. Uninstall and try again
  2. Re-install Windows to make sure the settings are gone.

Any help you could give would be appreciated.

  • Your question isn't completely clear. You've installed the Oracle 10G client, right? Put your tnsnames.ora in the %ORACLE_HOME%\network\admin directory. – Philᵀᴹ Feb 5 '13 at 14:53
  • @Phil yep the TNSNAMES.ORA file can be found there C:\oracle\product\10.2.0\client_1\NETWORK\ADMIN – Confused Feb 5 '13 at 14:54
  • open a cmd prompt and try tnsping MYDBNAME. You might have to add the Oracle bin path to the %PATH% – Philᵀᴹ Feb 5 '13 at 14:59
  • @Phil I get an OK response when I run that. No error. – Confused Feb 5 '13 at 15:06
  • Must be a PL/SQL Developer problem then. I don't use it, so can't help you I'm afraid – Philᵀᴹ Feb 5 '13 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.