3

While i am installing SQL Server 2008 R2 using the configuration file method I sometimes get an error in installation due to system reboot checking.

After restarting my PC, SQL Server installs properly. I want SQL Server setup to not check if the PC is rebooted or not. In SQL Server 2005 I can do this by using /norebootchk. How can I do this in SQL Server 2008 R2?

Also while installing in silent mode by using quiet=true I am getting a SQL Server command prompt while installing.

enter image description here

How can I avoid this command prompt appearing when I am installing in quiet mode?

4

To skip the reboot check:

SkipRules=RebootRequiredCheck

To hide the console window:

HIDECONSOLE=True

Full command line/.ini file options can be found here. The SkipRules option is not documented there and appears to be part of the general installer options.

| improve this answer | |
  • Could you please provide a source for the SkipRules option? I don't see it on that page. – Jon Seigel Mar 28 '13 at 14:35
  • i also didnt get information about skiprules in that page.Also hideconsole=true didnt work for me.i included it in config file – Navaneet Mar 28 '13 at 14:47
  • 1
    Yeah, as far as I can tell that's undocumented, part of the general installer options. I found references to it in various blog posts. You can find one such reference in this answer. I did included it and test it in an .ini and the log verified that the rule check was skipped. – Mike Fal Mar 28 '13 at 14:51
  • WOW.the undocumented "SkipRules" works perfectly.But the documented HIDECONSOLE=True didnt work. i will try once with /HIDECONSOLE in command line. – Navaneet Mar 29 '13 at 5:19
  • 1
    i used /HIDECONSOLE in command line and it worked fine – Navaneet Mar 29 '13 at 9:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.