Hello I installed Ubuntu 12.04.2 LTS on a fresh box.

This installed MySQL 5.5.29.

I installed percona-xtrabackup-2.0.6-521.tar.gz, and moved the executables to /usr/bin/

But innobackupex is giving an error: "sh: 1: xtrabackup_55: not found"

david@server1:/usr/bin$ sudo innobackupex --user=root --password=123 /home/david/dbb/
[sudo] password for david: 

InnoDB Backup Utility v1.5.1-xtrabackup; Copyright 2003, 2009 Innobase Oy
and Percona Ireland Ltd 2009-2012.  All Rights Reserved.

This software is published under
the GNU GENERAL PUBLIC LICENSE Version 2, June 1991.

130401 12:17:04  innobackupex: Starting mysql with options:  --password=xxxxxxxx --user='root' --unbuffered --
130401 12:17:04  innobackupex: Connected to database with mysql child process (pid=1488)
130401 12:17:10  innobackupex: Connection to database server closed
IMPORTANT: Please check that the backup run completes successfully.
           At the end of a successful backup run innobackupex
           prints "completed OK!".

innobackupex: Using mysql  Ver 14.14 Distrib 5.5.29, for debian-linux-gnu (x86_64) using readline 6.2
innobackupex: Using mysql server version Copyright (c) 2000, 2012, Oracle and/or its affiliates. All rights reserved.

sh: 1: xtrabackup_55: not found
innobackupex: fatal error: no 'mysqld' group in MySQL options

The files are present and executable:

david@server1:/usr/bin$ ls -l inno*
-rwxr-xr-x 1 root  root  108823 Mar 19 14:24 innobackupex
lrwxrwxrwx 1 david david     12 Mar 19 14:24 innobackupex-1.5.1 -> innobackupex
-rwxr-xr-x 1 root  root   10096 Jan 16 17:24 innochecksum
-rwxr-xr-x 1 root  root  400192 Jan 16 17:24 innotop
david@server1:/usr/bin$ ls -l xtra*
-rwxr-xr-x 1 root root  9799993 Mar 19 14:21 xtrabackup
-rwxr-xr-x 1 root root  8361704 Mar 19 14:24 xtrabackup_51
-rwxr-xr-x 1 root root 12699861 Mar 19 14:15 xtrabackup_55

Path is correct:

david@server1:/usr/bin$ echo $PATH

I get the same results if I run

sudo innobackupex 
sudo ./innobackupex 

Any ideas?

  • Dumb question, but have you tried this while not sitting inside /usr/bin? i.e., cd to a different directory first. Apr 2, 2013 at 3:35
  • yes I tried that
    – davidjhp
    Apr 2, 2013 at 3:49
  • what is your server bit? Is it 32 or 64?
    – Mannoj
    Apr 2, 2013 at 5:02

3 Answers 3


Check your server bit if it is 32 bit and if you try to install 64bit package percona's xtrabackup . It would end up throwing such error messages.

  • Ubuntu server was 64 bit, but had installed Perconas 32 bit version. Installing correct Percona software fixed the problem.
    – davidjhp
    Apr 2, 2013 at 19:05

Based on the error, looks like you don't have [mysqld] section in /etc/my.cnf file

  • Yes is is there. I think the real error is the one that is above: "sh: 1: xtrabackup_55: not found"
    – davidjhp
    Apr 2, 2013 at 3:51

Apparently if you make a backup with an older version of xtrabackup you need to restore it with an older version. From "yum provides *bin/xtrabackup_55" this is the most current version that contains that program. If I remove the current version and install with this:

yum install percona-xtrabackup-2.0.7-552.rhel6.x86_64

Then my recovery worked without throwing the above error.

  • Obviously the ubuntu user would have to use "apt-get install" instead of yum :D
    – Michae
    Jul 30, 2013 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.