I got a problem installing Oracle XE on Fedora 15. Hope you can help me.

I used this tutorial(that worked great for F14) but didn't got lucky with F15.

The problem is that during installation goes ok,but then I try to connect to the XE web without success.

So I tried this

su - oracle
./app/oracle/product/10.2.0/server/bin/sqlplus /nolog

and got this error

Error 6 initializing SQL*Plus
Message file sp1<lang>.msb not found

So I want to know what am I missing.

I thank your help in advance


Some thoughts:

  • First, I also have tried to get Oracle XE up and running under F15. Finally managed it, but it wasn't as simple as I would have thought it should be -- It's easier to get the silly thing configured under Ubuntu. IIRC, I just ended up installing EE instead (under F15).
  • Second, your environment needs to be set up correctly in your .bash_profile (in your home directory). Make sure to export ORACLE_HOME, ORACLE_SID (=XE), and make sure $ORACLE_HOME/bin is exported in your PATH. Once done, log out and back in and you should be able run sqlplus fine. (If you don't want to log out, just run ". ~/.bash_profile", and it should also work.)
  • Third, I don't know why Oracle doesn't set this up during the install process. And of all users not to have the environment set up (when XE usually has to create the user from scratch)... the oracle user should simply be set up with it from the start. But that's a rant and not really related to your question.

Hope that helps...

| improve this answer | |

This often means that you dont't have ORACLE_HOME set; and if your're having to give the full path to the sqlplus binary then you might not have $ORACLE_HOMR/bin in your PATH. You may not even have ORACLE_SID set. All of these can be set in the oracle user's .bash_profile so you don't have to do this manually every time. If any other user accounts will be used to connect to the database, they will need to be set in the environments for those users too.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.