Could the error shown on the screenshot be the reason why my site is very slow?

If so, I really need help to fix it since I am far from being an engineer!

  • 1
    This thread about this CPanel + Munin + InnoDb issue should set your mind at ease. The issue is caused by the way Munin counts free space.... – Martin Mar 13 '17 at 14:31

I wouldn't think this is why your site is very slow. You can change the alert levels by editing the following file:

vi /etc/munin/plugin-conf.d/mysql_innodb

In this file you should see:

env.warning 2147483648
env.critical 1073741824

If the tablespace falls below either of these levels a warning or critical is raised. Change these limits to whatever values (in bytes) you need. If you wish to completely disable this monitoring set the values to 0:

env.warning 0
env.critical 0

Restart munin:

/etc/init.d/munin-node restart
su munin -c /usr/bin/munin-cron
| improve this answer | |

InnoDB stores data in a tablespace. By default, there is one single tablespace and data of all the databases is stored in one file. This file has data dictionary, tables, as well as indexes in it. There is a global parameter innodb_data_file_path that defines this tablespace file. It has a syntax like ibdata1:256M:autoextend, this means at the beginning a file of size 256 MB will be created and then whenever the data size exceeds this, the file will be auto-extended. The innodb_autoextend_increment variable defines in MB's that by how much each increment should be.

Reference link wherein it has mentioned in depth about InnoDB tablespace which can be helpful to you : http://optimmysql.blogspot.in/2007/07/innodb-tablespace-size.html

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.