4

After changing my network password, I went straight to the SQL Server Configuration Manager (SQL Server 2008) to update the passwords for the SQL Server and SQL Agent services. (Background info: the services run under my domain account.)

However, I kept getting the below error after clicking on apply:

The specified network password is not correct. [0x80070056]

I guarantee the password entered was definitely the correct one because I have restarted my workstation and used it to log on successfully. Most answers on the web tend to focus on the password but I know that's just the symptom not the root cause.

I know it is difficult to answer questions like this one unless you have experienced it first-hand. So I am asking if anyone else has seen this behavior before and what they did to resolve it.

2

I have resolved it. Below is what I did and what fixed it.

  1. Ran "net user /domain " and made sure the account was still active and not locked or expired. (The account was active and healthy)
  2. Restarted the workstation. (The only thing it proved was the password was correct and I managed to log on successfully)
  3. Waited for couple of hours. (Sometimes you just have to be patient.)

After doing all of the above, the issue still remained. In the end, it was the action below that resolved it:

I went to the Services mmc snap-in under Control Panel -> Administrative Tools instead of SQL Server Configuration Manager. Changed the password there and started the SQL Server service successfully. Repeated the steps for SQL Agent.

It worked but I am still puzzled why it worked in Services but not in SQL Server Configuration Manager. Active Directory vs WMI? Anyone?

1
  • If there are multiple domain controllers, it is possible the password change hadn't replicated out properly throughout the domain, so you were seeing the results of that collision. I've seen all kinds of flaky problems when switching passwords with the "lag" while AD replicates the PWD around through the domain. To avoid that, I typically have 2 users, and switch between them, so the pwd has already had time to get sent around. – CaM Sep 26 '17 at 19:12
2

I was also able to get the SQL Agent Service to start using the Services mmc snap-in. I first used the Browse button to reselect the account and noticed that the Service did not return the pre-Windows 2000 Logon on name, the SQL Server Configuration Managers return the pre-Windows 2000 login name.

When I went back to the SQL Server Configuration Manager and opened the SQL Agent configuration, I noticed that it now contains the post-Windows format of the login name (@).

I'm running Windows Server 2012 and SQL Server 2012 and the older format (\) does not work when using SQL Server Configuration Manager.

0

For me the issue was slightly different. For certain accounts the IT Administrators had prevented log on to all Workstations.

The server I was setting up was not included in the allowed log on computers, hence it was failing to log on. Adding the server in AD meant the account could now run SQL Server.

Longon Workstations Dialog

0

I've seen this error when using the IP address of the computer instead of the computer name.

1
  • Using the IP address of the computer in a URL (\\192.168.0.1\MyFileShare) would result in the error, but using the computer name (\\ThatComputer\MyFileShare) would succeed. – Craig - MSFT Nov 2 '20 at 17:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.