0

I have installed pgadmin3 version 1.10.2, however when it connects to PostgreSQL server version 9.2, it says:

Warning:

This version of pgAdmin has only been tested with PostgreSQL version 8.4 and below and may not function correctly with this server. Please upgrade pgAdmin.

Then it will throw this error:

An error has occurred:

ERROR: column "datconfig" does not exist LINE 1: ...b.dattablespace AS spcoid, spcname, datallowconn, datconfig,...

etc.

Also I am quite stuck with my working version of pgAdmin3 as I am using Ubuntu Lucid. So is there a work-around for pgAdmin3 to work properly keeping my curent version of pgAdmin3?

migrated from stackoverflow.com May 30 '13 at 21:48

This question came from our site for professional and enthusiast programmers.

  • 3
    So your question actually is: how to install newer version of pgAdmin3 on Ubuntu? You should ask it there. – Danubian Sailor May 28 '13 at 8:02
  • No... i'm not asking that – xybrek May 28 '13 at 8:11
  • My question is, why pgAdmin3 can't properly connect to the DB server – xybrek May 28 '13 at 8:11
  • 2
    @xybrek Well, it explains that in the warning. PgAdmin needs to know some details about the server that are version specific. This version of PgAdmin is too old to know about 9.2, so it won't work reliably. – Craig Ringer May 28 '13 at 8:23
  • What kind of operating system is that, that doesn't let you install new versions? Can't you just download the binaries from pgadmin.org and install them? – a_horse_with_no_name May 30 '13 at 22:26
5

Other than not using features that cause errors, no, there is no workaround. Since in this case one of the features that causes an error appears to be listing tablespaces during startup, you're out of luck.

Just compile a newer version of PgAdmin-III from sources or use the command-line psql client that comes with PostgreSQL 9.2.

PostgreSQL's system catalogs aren't 100% compatible from version to version. That's intentional; if they had to be exactly the same it'd be very hard to make changes and improvements to PostgreSQL. Programs that use the system catalogs should be prepared to require updates when a new PostgreSQL version comes out. Most tools that use the catalogs - like psql, PgAdmin-III, pg_dump, etc - do so because it's the only way to get detailed information about some of the inner workings of the system. You just need to update them when you update the server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.