I'm currently using MySQL version 5.0.16, on my local computer (which runs a 32-bit OS), for easier access while developing my program.

Now that I'm ready to deploy my program, I'd like to test the connection over a network, and use a 64-bit server to hold the database.

Up til now, I've only used the 32-bit version, and my backup 'process' would be to copy the database folder from C:\Program Files\MySQL\MySQL Server 5.0\data and paste it onto the same directory of another computer.

I'm not sure if that would work.

I tried using both MySQL Query Browser and Command Line Client to do the following:

mysqldump -u root -proot Isys-TMS(EEI1) > isystms.sql;

But both simply return this error:

"You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'mysqldump -u root -proot Isys-TMS(EEI1) > isystms.sql' at line 1"

Which is not at all helpful. (Though I'm not sure if I did it right on the command line client, as opposed to Windows' own CMD)

I'm also assuming I can simply use this .sql output on the new 64-bit MySQL, so if that's not the case, what else can I do to solve this problem?



  • I'm using Windows 7 32-bit Pro, with MySQL Server 5.0 installed in it.
  • I'm planning to move the database to a Windows Server 2008 64-bit, with MySQL Community Server 5.6

EDIT: I actually used mysqldump, not mysqldumb. Quick, someone make a dumb/dump joke.

  • 1
    Waaaaaait! Are you trying to run mysqldump (yes, it's mysqldump, by the way, with a p, not a b) from inside MySQL?
    – Carsten
    Jun 4, 2013 at 9:04
  • Sorry, my mistake. I did use mysqldump, not mysqldumb. And yes, I used MySQL Query Browser. Jun 4, 2013 at 9:11
  • 1
    Well, that's wrong, so don't do that.
    – Carsten
    Jun 4, 2013 at 9:12
  • I see. So I use Windows Command Line? Jun 4, 2013 at 9:13
  • MySQL Query Browser or even HeidiSQL should be able to create a backup... What is the exact error in Query Browser? And by the way - you use Windows - please do not add a semikolon!
    – Andreas Rehm
    Jun 4, 2013 at 9:26

4 Answers 4


This is no SQL code:

"mysqldump -u root -proot Isys-TMS(EEI1) > isystms.sql;"

It is a commandline program like mysql.exe. You seem to run this in Query Browser or mysql cmd - this is wrong!

You can create a backup in Query Browser with the tool itself: http://www.siteground.com/tutorials/php-mysql/mysql_gui_tools.htm

or by running the mysqldump commandline from C:\Program Files (x86)\MySQL\MySQL Server 4.1\bin as:

mysqldump -u root -proot Isys-TMS(EEI1) -r isystms.sql

Please read this too (avoid \n / \r\n conversion): http://dev.mysql.com/doc/refman/5.1/de/mysqldump.html

Restore: http://www.siteground.com/tutorials/php-mysql/mysql_gui_tools.htm#restore


mysqldump is a separate binary and not a command within the MySQL console. Furthermore it is spelled with a p in the end (you had a b there!).

So just use your command on the ordinary command line and it should work.

> mysqldump -u root -p "Isys-TMS(EEI1)" > isystms.sql
  • Sorry, that was a typo, both the command AND the error message. I tried it on CMD, and it gets me an error 1146: Table 'isys-tms(eei1).toddeven' doesn't exist when using LOCK TABLES Jun 4, 2013 at 9:16
  • @zack_falcon Rest of the answer remains the same: Just execute in the command line (and not the MySQL console).
    – Sirko
    Jun 4, 2013 at 9:19
  • Yes, thanks, I did. It got me the error I posted on the comment above. I looked said error up on google, and tried mysqlcheck -uroot -proot "isys_tms_eei1" and the check said all the tables were okay. Jun 4, 2013 at 9:31

replace "mysqldumb -u root -proot Isys-TMS(EEI1) > isystms.sql;" by "mysqldump -u root -proot Isys-TMS(EEI1) > isystms.sql;".

Also, may be you can modify the database name to avoid parantheses

  • I'm so sorry, this is what happens when I fail to proof read. It was dump. And it still didn't work. I'll see what renaming the database does. Thanks. Jun 4, 2013 at 9:14
  • okk ... here's a suggestion --> lsys_TMS_EEl1
    – Archer
    Jun 4, 2013 at 9:17
  • Thanks. As per the other answers here, it was a mistake using MySQL query browser to do the command, as opposed to the command line. I'll rename the database and run it from CMD and see what happens. Jun 4, 2013 at 9:22

Properly escape the catalog name and mysqldump will work fine from the command line (the real command line, not the MySQL command line):

mysqldump -uroot -proot "Isys-TMS(EEI1)" > isystms.sql

And try to avoid ugly characters like parentheses in your database names in the future. Also prefer _ over -.

  • Thanks for the tips. I'll keep it in mind, and rename the database. Also, is there any difference between -u root and -uroot? Jun 4, 2013 at 9:18
  • Actually for mysqldump they're the same. Jun 4, 2013 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.