2

I need to increase the timeout period for schema comparison.

I'm using Visual Studio 2012 to compare two SQL Server 2008 R2 databases on Windows Server 2008.

I believe this is something I need to set in the Windows registry but I can't find where.

1
  • Is the database restored from different server and then you are doing the schema comparision ?
    – Kin Shah
    Jun 4, 2013 at 14:39

3 Answers 3

7

You have to increase the query timeout allowed on the connection. Unfortunately there is no user-interface-exposed way to do this. You have to search the Windows Registry for the key "QueryTimeoutSeconds" and increase the value. I increased mine from 60 to 360 and that made my schema compare timeouts disappear in Visual Studio 2012 and Visual Studio 2013.

1
3

Advanced settings in connection has that ability

enter image description here

0

You can adjust this setting by opening your schema comparison and editing the connection which is timing out (source or target). Click the Advanced button and set the Connect Timeout property to a higher value than the default of 15.

2
  • 1
    Can you provide a little more information and possibly a screen shot or two?
    – Erik
    Sep 22, 2015 at 15:19
  • This setting didn't work for me. I believe there needs to be another settings for the query timeout (vs. connect timeout) not sure though...
    – Josh M.
    Nov 27, 2015 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.