3

We use WUXGA displays (1920 x 1200), and have lots of SSRS reports. Since these reports need to be printed once in a while the layout is adjusted to A4. However when the users look at the reports on the display around 40% of the screen is blank. Absolut waste of screen space. How can I adjust SSRS to use the full screen size for reports ?

1
  • Just change the report 'interactive size' to one that looks best for you.
    – Eric
    Jul 18, 2013 at 19:10

1 Answer 1

3

If you are using the web interface to run and view the reports there is an option to set the zoom level by appending &rc:Zoom=Page Width or whatever percentage you want.

Also it can be configured in the SSRS configuration file see MSDN for details.

9
  • This is pretty good, but is there any way to do this so that the report doesn't appear stretched when zoomed? (This might be a limitation of SSRS.)
    – Jon Seigel
    Jul 11, 2013 at 13:32
  • Can you try setting the Report property ConsumeContainerWhitespace to true and see if that helps? Jul 11, 2013 at 16:42
  • That didn't seem to help. I think that setting has something to do with the canvas in the designer.
    – Jon Seigel
    Jul 11, 2013 at 16:51
  • Can you try exporting it in PDF, and opening it in the same zoom level and see if it renders the same? Jul 11, 2013 at 17:07
  • I suppose I should mention that the entirety of my report is a graph, so there may be no way to fix that. I'll try what you suggest anyway just to see what happens.
    – Jon Seigel
    Jul 11, 2013 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.