0

I have a problem with oracle 11g database,

I have shutdown my computer this morning normally, but in the evening when I tried to connect to my database I fond a problem. I cannot connect as normal user so I tried to connect as sysdba to shutdown the database and remount it (this works normally). Now when I try to open it (the database) I got this error :

ERROR in line 1 : ORA-00600: Internal error code, arguments : [kcratr_nab_less_than_odr], [1], [90], [13770], [13771], [], [], [], [], [], [], []

Can any one help me please ???

1
  • ORA-600 => support.oracle.com - Search there, you'll most likely find what you need.
    – Mat
    Commented Jun 18, 2013 at 4:22

1 Answer 1

0

Your situation looks most like a powerfailure. This kind can hurt the database badly and in this case it looks like the controlfile or the online logfile is damaged. If you have a backup, start with restoring the controlfile from the backup and recover the database using the backup controlfile option.

With a little luck you can open the database afterwards. With a little bad luck, the damage is in the online redolog in which case you can not open the database in a consistent state. This is because your undo segments are active and they lack to recovery information from the redolog file to recover from that.

Still it is possible to open the database using some tricks but it does require extra work, setting hidden parameters etc. After that type of 'recovery' only export -> create new db -> import is a valid option.

2
  • As I am working locally and I don't have much time, I uninstalled Oracle and its services and installed them again, restored my Database and it's working now. Commented Jun 18, 2013 at 5:34
  • ok, so you had a backup. Lucky you, this saved you a lot of time. The reinstall was not needed, you could have restored it right away, without reinstall (I think even for windows).
    – user953
    Commented Jun 18, 2013 at 5:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.