6

I tried all three method explained here to max_allowed_packet. But no one changes its value in my MySQL 5.6.

I use show variables like '%max_allowed_packet%' to see its current value. But it always is 12582912.

Only changing its value in my.ini is effective.

What is wrong?

13

You have two values of max_allowed_packet in MySQL :

  • one on the client side : [mysql] section, [mysqldump], [client] and more.
  • one on the server side : [mysqld] section.

The value of max_allowed_packet you see with the command show variables like 'max_allowed_packet'; is the one on the server side.

In order to increase this value, you must increase both sides : in your server configuration file ([mysqld] section in your my.ini file) and in your client configuration file (whether your [client] or [mysql] section in your my.ini file).

This setting can be changed on the server side without restarting the server if you have the SUPER privilege with this command : mysql> SET GLOBAL max_allowed_packet = numeric;.

Don't forget to change the 'numeric' value by a numeric value. Don't forget to change your configuration file too otherwise this value will be reset at reboot.

3

What worked for me was

  1. Start MySQL Workbench 5.6 (tested up to version 6.3)
  2. In the navigator go to Instance options file. If the file cannot be found, then create it yourself at /etc/my.cnf:
# /etc/my.cnf
[mysqld]
  1. Click on the Networking tab
  2. Enter 16M (or any size you wish to have) in the max_allowed_packet edit box, click apply and restart mysql
  3. SHOW VARIABLES LIKE 'max_allowed_packet'; will now give 16777216.

Alternative

You can set the max_allowed_packet directly on the my.cnf file as follow:

# /etc/my.cnf
[mysqld]
max_allowed_packet=16M
1

MAX ALLOWED PACKET DOCUMENTATION

This value indicates maximum size of one packet, The packet message buffer is initialized to net_buffer_length bytes, but can grow up to max_allowed_packet bytes when needed. This value by default is small, to catch large (possibly incorrect) packets. You must increase this value if you are using large BLOB columns or long strings. It should be as big as the largest BLOB you want to use.

This server variable can be set globally by running a query.

However, if you do not change it in the my.ini/my.cnf file, the value will reset when the server restarts, even if you set it globally.

To change the setting for everyone until the server restarts:

SET GLOBAL max_allowed_packet=1073741824;

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.