• I tried to add a new node to SQL Server (2012 Standard) Failover, that is already installed on another node in Windows2012 Failover Cluster
  • I have an issue with non editable field wiht input for SQL Server Agents Account Name
  • there could be the same AD name as for SQL Server Database Engine (e.i.)
  • my account access haven't AD admin privileges
  • access, account and setting for SQL Server Agent on parent node are accesible and settable

enter image description here

  • Go into the active node of the failover cluster and verify that SQL Server Agent is actually a cluster resource of your FCI cluster resource group. You can do this with PowerShell as well: Get-ClusterGroup -Name "SQL Server (MSSQLSERVER)" | Get-ClusterResource (change the name to whatever your cluster resource group name is for your FCI). You may need to import the failover clusters module depending on what version of PowerShell you are on (Import-Module -Name failoverclusters). Jun 26, 2013 at 14:03
  • If SQL Server Agent isn't part of the cluster resource group, and if it's not a resource type in the cluster then that can cause the problem you are seeing. If that is the case, in your situation, then I can show you how to fix that. Jun 26, 2013 at 14:04
  • @Thomas Stringer to 2. comment I tried to change account for this component from built_in default account and ended with AD admin access, nothing changed when I tried to add a new node to a SQL ..., looks like as isn't clustered, but no idea why, because all shared features I redirected to clustered disk in initial instalation processes
    – mKorbel
    Jun 26, 2013 at 14:15
  • 1
    Answer posted below, let me know if that works for you. You shouldn't have to create a new cluster to get this one up and running. Jun 26, 2013 at 18:07
  • 1
    If anyone is interested in a complete walk-through of the solution for SQL 2008 R2, see this: mssqltips.com/sqlservertip/2592/…
    – Mentok
    Sep 16, 2015 at 19:03

1 Answer 1


As per your comments in your question, what you need to do is two-fold:

  1. Add SQL Server Agent as a cluster resource type
  2. Add the SQL Server Agent cluster resource to the failover cluster resource group

For the first step, one way to do this is through PowerShell (utilizing the FailoverClusters module):

Import-Module -Name FailoverClusters

$ClusterName = "YourClusterName"
$FciClusterGroupName = "SQL Server (MSSQLSERVER)" # may need to modify to reflect your environment

# check to see if you have the SQL Server Agent cluster resource type
Get-Cluster -Name $ClusterName |
    Get-ClusterResourceType |
    Where-Object {$_.Name -eq "SQL Server Agent"}

# if not, add it
Add-ClusterResourceType -Name "SQL Server Agent" -Dll "sqagtres.dll"

Execute each of those blocks of code separately instead of just all at once. You'll be able to confirm whether or not that cluster resource type exists before just blindly attempting to add it.

Then for the second step, here's what you need to do to add the SQL Server Agent as a resource in your failover cluster resource group:

  1. Right-Click on your FCI resource group within the failover cluster manager
  2. Select "Add a resource" and select the SQL Server Agent resource type
  3. Rename the new cluster resource to "SQL Server Agent"
  4. Go into the new SQL Server Agent resource properties and set the virtual network name and instance name properties
  5. On the dependency tab, set SQL Server as its dependency resource

You may need to go into the registry at the following location and ensure those keys (one will contain the string "AGENT", another "SQL_ENGINE") are set to 1 (this is where it is recorded on what was installed correctly. 1 denotes correct installation):

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\YOURINSTANCE\ConfigurationState

That should get you to a place where you can now install an additional node and have the SQL Server Agent service account appear. Of course, prior to starting ensure that you have a back out here (especially with the registry editing).

  • @mKorbel No problem, glad to help. Did it work? Jun 26, 2013 at 18:47
  • again thanks, very similair steps :-) .......
    – mKorbel
    Jun 27, 2013 at 5:34
  • real issue was access to create a new Objects in AD (must be manually added) for Failover instance
    – mKorbel
    Jul 1, 2013 at 13:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.