I'm working with a SQL Server with several instances. Four of my instances are at 10.50.2811.0 and the remaining two are at 10.50.1765.0

I've tried running SQL Server 2008 R2 SP1 and CU 6 to get it updated but the installer wont run. I receive the error:

To continue, select a feature to install. If all features are already selected, these features are installed.

closed as off-topic by jcolebrand Jul 16 '13 at 19:03

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Too localized - this could be because your code has a typo, basic error, or is not relevant to most of our audience. Consider revising your question so that it appeals to a broader audience. As it stands, the question is unlikely to help other users (regarding typo questions, see this meta question for background)." – jcolebrand
If this question can be reworded to fit the rules in the help center, please edit the question.


Basically, you have to install SP1 and then CU6 (as mentioned in my comment)

  • 10.50.2811 ==> 2679367 Cumulative update package 6 (CU6) for SQL Server 2008 R2 Service Pack 1
  • 10.50.1765 ==> 2489376 Cumulative update package 6 (CU6) for SQL Server 2008 R2 note this is for RTM
  • When we tried to install SP1, it get an error message. I thinks it's already installed. – Bryan Smith Jul 12 '13 at 14:44
  • Check the version - select CAST(SUBSTRING(@@Version, charindex('SQL', @@version, 1), 30) AS VARCHAR(max)) + ' + ' + CAST(SERVERPROPERTY('productlevel') AS VARCHAR(50)) + ' + (Build' + CAST(SERVERPROPERTY('ProductVersion') AS VARCHAR(50)) + ')' as ProductVersion – Kin Shah Jul 12 '13 at 15:04
  • Thanks for the suggestions on this. Our consulting vendor ended up figuring the problem the second time around. – Bryan Smith Jul 16 '13 at 12:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.