In our environment multiple users each work with their own copied front-end, with tables linked to a single networked back-end (both files are .mdb).

Each user has permissions to read and write to the location of BE, and both FE and BE are set to "shared access".

Recently a single user started getting error: 3045 "Could Not Use Database; File Already in Use" while trying to open forms using linked data.

The same error appears while trying to re-link the tables using the manager. All other users can still normally work.

Tried restarting his workstation, removing local files and re-copying the FE and it didn't work.

There is no .ldb file left after all users turn off the FE, compacting after that and restarting the FE of the unlucky user didn't help either.

Said user is working on AC2010, but some others are working on AC2007 and AC2003.

Please help!

edit: BE is stored on Windows Server 2003.

  • 1
    What kind of machine is the BE on? XP has a limit of 10 connections (incoming). Also, when it happens, have you tested other network connectivity (ping between both machines) to confirm that there is not a network/NIC problem?
    – TimG
    Jul 25, 2013 at 12:47
  • I'll check the ping tommorow, although it's probably not the source of the problem (no visible delay nor errors on moving around and copying files to and from the location).
    – Faiir
    Jul 25, 2013 at 15:35

1 Answer 1


Turns out the problematic user could create new files and delete them in the location, but did not have permission to delete files made by other users due to changes made by our IT.

As such the problem is now resolved.

Thanks to everyone who read and sorry for taking your time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.