3

I have a backup of my database as a TestDatabase.bak file but I am unable to restore it.

When I try to restore I receive the following error message in SSMS:

RESTORE could not start database 'FieldopsDevDynamic07042013'

SSMS error message

The error log shows:

Database 'FieldopsDevDynamic07042013' cannot be started because some of the database functionality is not available in the current edition of SQL Server.

Error log message

How can I restore this database?

1
  • 1
    How did you restore the database - more specifically, did you specify WITH NO RECOVERY? You can try RESTORE DATABASE <yourdbname> WITH RECOVERY Aug 2 '13 at 16:38
5

Your backup is from a database that is using Enterprise Edition features. You are trying to restore it to an Express Edition server. That will not work.

The message in your error log is telling you exactly that:

Database 'FieldopsDevDynamic07042013' cannot be started because some of the database functionality is not available in the current edition of SQL Server.

The error log even tells you which feature is causing the problem:

Database 'FieldopsDevDynamic07042013' cannot be started in this edition of SQL Server because it contains a partition function...

Try restore to an Enterprise or Developer edition server. If it still fails update your question with the result of your attempt.

2

You have to execute below t-sql in a query window :

--recover the database:
RESTORE DATABASE db_name WITH RECOVERY;
GO

You might have selected "restore with NORECOVERY" as below. You have to select "RESTORE WITH RECOVERY" to bring the database out of restoring state.

enter image description here

7
  • I tried as per your suggestion. But it is giving an error after restoring 100%. I am uploading an error message snapshot please go through it.. Aug 3 '13 at 6:44
  • Can uou post the error messages from the error logs as well ?
    – Kin Shah
    Aug 3 '13 at 13:11
  • I have posted error log. Please check it. Aug 3 '13 at 13:23
  • I also have .sql, .mdf, .ndf and .ldf files of same database. I also tried to attach .mdf file to restore may database. But still it is giving an error. I am posting an error message for mdf file. please go to First Image. Aug 3 '13 at 13:28
  • 5
    The problem is that the database uses partitioning (an Enterprise feature) and they are trying to restore the database on a lesser edition. No RESTORE command is going to make this work on their current instance - they need to restore to an equivalent edition, or go back to the source, restore a copy there, remove partitioning (and any other Enterprise features), and then backup that copy and restore it. Aug 3 '13 at 18:45
-4

I dont know if this will help or not...but with some of the older versions of SQl if you had a file still open, it would keep processing until all files were closed. Make sure you have closed all files/connections. That might help you.

3
  • I have closed all files even I have also restated my system. But still it is restoring. Now what should I do.? Please help me...Thank you.
    – user2586685
    Aug 2 '13 at 14:04
  • "I've tried what you accepted and it didn't work what should I do" Start with unaccepting the answer.
    – Zane
    Aug 2 '13 at 20:10
  • 4
    This answer is completely wrong. A database file isn't marked as restoring if it's open by whatever process. A db is marked as restoring if it's in the process of restoring. Nothing else can set a db in this state.
    – Marian
    Aug 2 '13 at 20:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.