I did most of the solutions provided here.

I know about

  • enabling IntelliSense
  • clearing the cache
  • connecting to a server >= SQL Server 2008
  • using the latest SQL Server Service Pack

and it works locally with the SQL Server 2012 engine.

But it still does not work when connecting to a SQL Server 2008 SP1 engine from my SSMS 2012. If I do


I get 10.0.2573.0 as result. So the server is 2008 SP1.


After a few days it started working. I don't know why.

  • SQL Server Management Studio 2012 is the only environment that supports SQL Server Intellisense. Have you tried a server side trace to see if the Intellisense session is getting errors?
    – Hannah Vernon
    Sep 4, 2013 at 14:24
  • 2
    @MaxVernon Intellisense has been in SSMS since 2008. technet.microsoft.com/en-us/library/bb934481(v=sql.100).aspx
    – user507
    Sep 5, 2013 at 13:24
  • Hmmm... Thanks for pointing that out Shawn. Clearly I'm wrong about it not being supported in 2008. Still, a server side trace should allow the OP to see what is happening/not happening with Intellisense, right?
    – Hannah Vernon
    Sep 5, 2013 at 13:53
  • @MaxVernon and how do you do that? I have a problem with SQL Server 2008 R2 (10.50.1617) and SSMS 2012 - IntelliSense not working...
    – Azimuth
    Oct 16, 2014 at 7:37

2 Answers 2


Try patching your server. I attempted to recreate your issue with SSMS 2012 (11.0.3000) by connecting to four servers: one SQL Server 2008 (10.0.1600) and three SQL Server 2008 SP 1 (10.0.2531). As you can see the only difference between the four servers is one server does not have Service Pack 1 installed. On all of the servers with service pack 1 installed intellisence worked without issue. However, intellisence did not work on the server without service pack 1 installed.

You can download the service pack here. http://www.microsoft.com/en-us/download/details.aspx?id=20302


Not sure if others are running into this issue still, was surprised to run in to the issue as the setup at works was essentially a clean install. Normally if/when there are errors like this it is more often older installs where you have installed multiple versions of SSMS and VS, and all associated Service and Security Patches...

Okay, long story short, what appears got intellisence was going into my specific login for and fixing up my user mapping to the database I wanted intellisence for. I also tested after adding the "User Mapping" and getting the intellisence perfectly find for the DB, then removing my mapping, , and adding my user mapping back and having it work again...

So where intellisence is not working for you start by adding an explicit "User Mapping" for you log-in to the database in question, seemed to work perfectly find for me.

Hope this helps others.

dan d:)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.