SQL Server 2008 R2 RTM running on Windows 2008 64bit.

Having problems backing up a single database with the following command

backup database [somedatabase] 
to disk = '\\somehost\d$\BACKUP\somedirectory\some_database.bak'
with compression, init, stats=1

The database backs up just fine for a while

93 percent processed.
94 percent processed.

Then I get an error about diskspace

Msg 3202, Level 16, State 1, Line 1
Write on "\somehost\d$\BACKUP\somedirectory\some_database.bak" failed: 1130 (Not enough server storage is available to process this command.)
Msg 3013, Level 16, State 1, Line 1
BACKUP DATABASE is terminating abnormally.

This doesn't make any sense because there is over 800GB of available disk space and the backup is using 121GB.

In SQL Server's logs I get this message

Date        9/25/2013 1:04:56 PM
Log     SQL Server (Current - 9/25/2013 12:15:00 PM)

Source      Backup

BackupIoRequest::ReportIoError: write failure on backup device 
'\\somehost\d$\BACKUP\somedirectory\some_database.bak'. Operating 
system error 1130(Not enough server storage is available to process
this command.).

Some information:

  1. Backups are being executed from the server locally and the backup files are being saved to \\somehost which is another server close by.

  2. Both the local and remote hosts have sufficient disk space.

  3. Compression is on

Any assistance on getting to real cause of these backup failures would be appreciated.

Thank you

Update 16:48

As of R2, Compression is a backup option on standard. Thank you RLF. Still having the same problem with or without. The only difference is that the backup fails at 18% without compression. Decided to monitor disk space to make sure nothing else was eating up GB during the backup.

Free space during backup

As expected, available disk space went down to 600GB while using compression and 400GB without. Disk space never dipped below 400 though.

  • try backing up locally and then move the backup to a n/w location. See if that works. Also, the error is complaining about disk space.
    – Kin Shah
    Commented Sep 25, 2013 at 12:54
  • 1
    You say "Compression is on". Does that mean database backup compression? If so, good. Or does that mean file compression is turned on for the backup share? If so, then that is likely the problem. (From experience.)
    – RLF
    Commented Sep 25, 2013 at 13:27
  • 1
    You are running SQL Server 2008 R2, which can do compression on Standard Edition just fine. As others have pointed out, the error is clear, the reason for the error is unclear. Possibilities (1) there is a storage problem or a network problem that kills the backup, (2) someone else is doing something that eats up storage and perhaps both fail,(3) the target share is using Windows compression and therefore reports an 'estimated size' that may not actually reflect how much data can be stored. (Or one of the things I did not think of.)
    – RLF
    Commented Sep 25, 2013 at 14:42
  • 1
    Is the share you're backing up to SAN storage or direct attached to the other host? If it's SAN, it could be thinly provisioned, which could create your error.
    – Mike Fal
    Commented Sep 25, 2013 at 15:29
  • 1
    Have you run chkdsk on the target volume?
    – Jon Seigel
    Commented Sep 25, 2013 at 17:30

1 Answer 1


The error not enough server storage available is misleading. This is not disk space, but Windows SMB management memory. Try restarting the target machine (where the backup is being saved), or at least restart the Server service.

See the following Microsoft support link for instructions on potential registry changes that may be necessary at the machine where the backup is being stored.


Also, you might try a search for "Windows Server error 1130" for more info.

  • 1
    Hello Max, I will try out restarting the server service and get back to you shortly. Commented Sep 26, 2013 at 7:15
  • Attempting restart of the server. Restarting the server service did not resolve the issue. Commented Sep 26, 2013 at 15:05
  • 1
    Following the recommendations from the KB link worked. Thank you Max for your help. Commented Sep 26, 2013 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.