1

I'm having troubles seting up DB2 Express-C 10.1 on my Mac OS X (v10.7.5). My initial install attempt failed, but then I found

https://www.ibm.com/developerworks/community/forums/html/topic?id=77777777-0000-0000-0000-000014927797

That seemed to work up to the point where I tried to start the db:

$ ./db2start 
dyld: Library not loaded: /db2unix/db2galileo/db2_galileo_darwinport/darwin64/s120905/engn/lib/libdb2e.dylib  
Referenced from: /Users/home/sqllib/adm/./db2start  
    Reason: image not foundTrace/BPT trap: 5
$

OTOH, if I try to run db2setup from the expc directory I get and error message that others have seen. Something like

/Applications/expc/db2/macos/install/db2setup: line 606:     
/tmp/db2.tmp.22412/db2/macos/install/../java/jre/bin/java: No such file or  directory

Where the 5-digit number in the tmp directory name changes on each run.

That is followed by a nice DB2 10.1 intro screen which is suddenly replaced by a blank DB2JDKTester window that says "DB2 SETUP LAUNCHPAD" at the top.

Has anyone else tried to install DB2 on Mac OS X 10.7?

(And, yes, I've seen the other thread with the same title, but that was never actually answered.)

2

I got it working by completely uninstalling db2 express-c (the db2_deinstall script failed so I manually deleted all directories that involved db2. :P ) .

Then I followed https://www.ibm.com/developerworks/community/forums/html/topic?id=77777777-0000-0000-0000-000014927797

and it worked. I never ran db2_setup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.