I have a database using innodb completely. Its now having a innodb_buffer_pool_size at 128MB. Which I know is very less for my user.

But no matter what I do it won't change. I have added a value of 1G both in /etc/my.cnf and also in /etc/mysql/my.cnf and restarted the mysql service. It doesn't seem to update.

My mysql keeps on stopping and when i run mysqltuner & tuning-primer.sh all point to the fact I have to increase the innodb_buffer_pool_size but it simply won't increase.

Is there any other way to enforce this?

  • How did you identify your current buffer pool size?
    – BilliD
    Commented Aug 18, 2017 at 17:02

2 Answers 2


Adding the values to a new my.cnf file inside, /etc/mysql/conf.d solved the issue. Added only the value we wanted to override. For some reason, values added elsewhere were ignored by mysql.

Note: Make sure /etc/mysql/conf.d is included in my.cnf file located at /etc/mysql/my.cnf. It included by default.


Make sure that you are adding innodb_buffer_pool_size and it's value in mysqld section of my.cnf file of a MySQL server you would like to change.

Not the answer you're looking for? Browse other questions tagged or ask your own question.