I have a PostgreSQL 9.3.1 DB Server running in Windows 7 Ultimate. I have checked the file postgresql.conf and this lines are uncommented:


And this is the configuration at pg_hba.conf file:

# TYPE  DATABASE        USER            ADDRESS                 METHOD

# IPv4 local connections:
host    all             all               md5
host    all             all             md5

# IPv6 local connections:
host    all             all             ::1/128                 md5

# Allow replication connections from localhost, by a user with the
# replication privilege.
#host    replication     postgres           md5
#host    replication     postgres        ::1/128                md5

Apparently all is fine but if I run the command netstat -an I don't see the port 5432 open to any host unless this line: 

means that. The problem is I can't connect from any PC in subnet 192.168.1.x and the message says PostgreSQL isn't installed on the PC or it doesn't listen. I have disable any firewall in all PC looking for a solution but can't. Can any help me to find the problem here?


This is the error I'm getting:

enter image description here

  • Please post the exact error message! – Milen A. Radev Oct 16 '13 at 14:10
  • @MilenA.Radev basically the error looks like the one showed in the picture (see edition) but pointing to my local address and port 5432 – Reynier Oct 16 '13 at 15:06
  • does indeed mean that it's listening on all addresses at port 5432. – Colin 't Hart Oct 16 '13 at 15:18
  • 1
    And this is from the same client PC that you've tried to connect using your PG client (looks like PGAdmin)? – Colin 't Hart Oct 16 '13 at 16:12
  • 1
    There is a typo in the pg_hba.conf: 127 should be 192 on the second uncommented line -- assuming this line is meant to allow password connections from the LAN. But this should give a different error than the one you report. – Colin 't Hart Oct 16 '13 at 16:14

i have the same problem. I disabled all my third party antiviruses and firewalls and reinstall PostgreSQL again and its now working fine... :)

Not the answer you're looking for? Browse other questions tagged or ask your own question.