I am trying to install SQL Server 2012 Express on a Windows 2012 Server for test purposes. This machine is part of our company domain.

During installation I am trying to use one of domain account for SQL Server Database Engine service but it is failing with following error,

"The SQL Server service account login or password is not valid. User SQL Server Configuration Manager to update the service account."

I have verified both domain user and password. And this account has "Log on as a Service" permission enabled. I have also added this user into local admin group but still no go.

Any suggestion is appreciated.

  • You can change the service accounts after the installation. Probably the account is not having proper rights.
    – Kin Shah
    Commented Oct 24, 2013 at 15:26
  • @Kin That could be the reason. But AFIK, since this account is member of local admin group it does have all rights it need, no ?
    – JackLock
    Commented Oct 24, 2013 at 15:29
  • Local Admin group should have all the rights. As I said, you can change the service accounts after installation. I cant think of anything other than that. Since this is a test box, you can try rebooting the box.
    – Kin Shah
    Commented Oct 24, 2013 at 15:54
  • 1
    Ok, so after installing SQL Server with default service I tried to change to account that I wanted to use.. and guess what ? ... it worked !!
    – JackLock
    Commented Oct 24, 2013 at 17:58
  • Glad that it worked ! Sometimes the installer gets cranky. I also faced the same issue and used the local account for installation and then changed the account to the one that I wanted.
    – Kin Shah
    Commented Oct 24, 2013 at 18:24

2 Answers 2


The issue isn't with the account you are attempting to use, but your account. If you look in the setup log file, which is created during the installation of the SQL Server application, you will see the details of the issue, with technical jargon that will indicate the issue is probably a permission issue with your account having permission to perform a check on the service account credentials:

Slp: Sco: Attempting to check if container ‘WinNT://DOMAIN’ of user account exists
Slp: UserSecurity.ValidateCredentials — Exception caught and ignored, exception is Access is denied.
Slp: UserSecurity.ValidateCredentials — user validation failed

Rebooting usually fixes this issue, as does changing the service account value after installation is complete. A minor issue that sometimes appears.


Un check the "User must change password at next logon" for the user in Computer management and restart the installation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.