I have been trying to backup data with structure from my old legacy server to my local server for modifications. PhpMyAdmin timed out at the time of export, MySQL Workbench has performed connections between source and target machines as Ok and upto bulk data transfer everything went well, after that point I am getting errors as "Connection using old(pre-4.1.1)authentication protocol refused(client option secure_auth enabled)although I checked disable_auth in Advanced tab. Error: Error getting row count from source tables.

Any suggestions relating to this would be useful.


Please read this but report:


The workaround ("solution", really) to this is to change the password for the affected user to a post-4.1 hash. This is really a recommended best practice, regardless - password hashing and authorization process prior to 4.1 has notable security limitations (discussed in documentation at http://dev.mysql.com/doc/refman/5.0/en/password-hashing.html). Restoring a 4.1 version of the mysql schema on to a 5.6 server is a bad idea at any rate, because 5.6 has additional columns in some tables and some completely new tables, which may or may not be missing now depending on how you configured mysqldump when you created the dump file. You may have caused other problems that you may not see immediately.

Also, specify skip-secure-auth option in [mysqld] section of my.cnf/my.ini file of your MySQL server and restart it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.