2

I tried to change default language to french by using the below query.

USE ssidps;
GO
EXEC sp_configure 'default language', 2 ;
GO
RECONFIGURE ;
GO

but SELECT @@language gives "us_english" always.

My aim is to change my onshore system's default language from korean to english. All error/warning messages are coming in korean when query failed. And i couldn't catch that message as i developed in English.

Its working in the current session by the query "set language french" but not for the database. I asked the same in stackexchange but i was referred to this site. https://stackoverflow.com/questions/19654101/how-to-change-default-language-of-sql-server-management-studio

  • Please don't cross-post. – Jon Seigel Oct 29 '13 at 17:23
3

Using SSMS :

To do so, open SQL Server Management Studio (SSMS) > Right click Server in Object Explorer > Properties > Advanced > Check the ‘Default Language’ property and make sure it is set to the one you want.

enter image description here

using TSQL:

Look up the sys.messages catalog view to check if SQL Server supports a message in your local language.

SELECT msg.language_id, lang.langid, alias 
FROM
sys.messages AS msg
JOIN
syslanguages AS lang
ON lang.msglangid = msg.language_id
GROUP BY  msg.language_id, lang.langid, alias

then once you know the langid use below tsql

EXEC sp_configure "default language", n  -- n = `langid` that you want to set
RECONFIGURE WITH OVERRIDE;

note: you have to restart SQL server and this is an instance wide setting.

  • I have tried these before. Any way i have re-install SQL server 2008R2 with certain language. – sameer pradhan Oct 30 '13 at 11:26
  • 1
    +1 for giving the TSQL source. Changing from the UI was disabled for some reason. – Sammy S. Aug 14 '15 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.