I am trying to install Oracle 12c in a Windows 7 x64 computer and after a while I get this error:

SEVERE: [FATAL] [INS-30131] Initial setup required for the execution of installer validations failed.
   CAUSE: Failed to access the temporary location.
   ACTION: Ensure that the current user has required permissions to access the temporary location.
- Framework setup check failed on all the nodes
- Cause: Cause Of Problem Not Available
- Action: User Action Not Available
Summary of the failed nodes
- Version of exectask could not be retrieved from node "XXXXXX"
- Cause: Cause Of Problem Not Available
- Action: User Action Not Available

Does anybody have an idea how to solve this problem?

  • Sounds like you're trying to install it without admin privileges. – Philᵀᴹ Nov 1 '13 at 10:42
  • 2
    Nope :) I am dumb but not THAT dumb. – Yván Ecarri Nov 1 '13 at 11:17
  • In my case there was no C$ share. I shared with admin only permissions and did the trick. – pmesina Mar 12 '14 at 22:02
  • I've too low reputation to answer, so as comment... For me the culprit was non-US-ASCII character in my user name (Én). First I've set TEMP and TMP to an accent-free path. But the installer creates folders inside %TEMP% like CVU_12.Én and hsperfdata_Én, and later it tries to access them with corrupted names, so it still fails. So when the error dialog popped up, I created links with the corrupted names (as mklink /J CVU_12.Én CVU_12.Én and mklink /J CVU_12. CVU_12.Én, etc.), then retried by pressing "Next" again, and it worked. – ddekany Jun 29 '18 at 19:39

I found the problem. For reasons I don't understand Oracle needs access to the file system through the administrative network share (i.e. \computer\c$) and I had disabled it.

Things to check to solve this issue:

  1. Remove your computer from workgroups.
  2. Set HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System DWORD value LocalAccountTokenFilterPolicy to 1
  3. Set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanServer\Parameters DWORD value AutoShareWks to 1

I finally got the answer for this error, this was because of the machine name being big. While setting up a new machine we should ensure that the machine name is not bigger then the bios name. which is 15 chars. This will definitely work.

  • One of my colleagues had this problem. As Incredible as it might seem, his PC name had 16 characters. After changing to less than 15, the installer worked! – XMight Mar 3 '16 at 10:41
  • This was the problem in my case. Renamed the machine, installation succeeded. Thank you! – Andreas Jan 9 '18 at 7:08

Extending the answer from Y.Ecarri above,

  • Ensure the Server service is started. Go to run box and type services.msc. This should bring up the Services console.

  • Type \\<your-computer-name> in the run box and check if you're able to see the shared folders.


I had the similar issue and failed even after trying many solutions.

Finally, I end up doing the following which might help some one but strongly advise you not to do this production environments.

Following Workaround is available to install database/client software if administrative shares is not enabled :

 For client installs, run the installer with following arguments:

setup.exe -ignorePrereq -J"-Doracle.install.client.validate.clientSupportedOSCheck=false"

 For server installs, run the installer with following arguments:

setup.exe -ignorePrereq -J"-Doracle.install.db.validate.supportedOSCheck=false"

Not the answer you're looking for? Browse other questions tagged or ask your own question.