I created an application that is making use of MSDTC (to open a transaction on multiple databases within the same MS SQL server), our local environment was setup successfully and both DTCPing, DTCTester and the application work. However when it came to deployment I encountered issues when setting up the client computer to make use of the server's coordinator.

On Client site I have tried the following:

  • DTC Ping passed successfully
  • Setting Coordinator to the server one results into the following error "The specified remote host machine does not exist"
  • I am able to ping the server using host name

When I tried running DTC tester, it output the following:

Executed: dtctester.exe
DSN:  accdim
User Name: sa
Password: <hidden>
tablename= #dtc16397
Creating Temp Table for Testing: #dtc16397
Warning: No Columns in Result Set From Executing: 'create table #dtc16397 (ival int)'
Initializing DTC
DtcGetTransactionManager failed: 8004d01b
DtcGetTransactionManager Call Error: Indicates unable to connect to the transaction manager, or the transaction manager is unavailable.

This ended out being a domain policy issue, the computer was moved to an other group and MSDTC was registered and working successfully.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.