On my server I have 6 MySQL databases. They all power Wordpress websites. For some reason, 2 of these databases are not accessible. To my knowledge they use INNODB, but I can't confirm it as even doing a:


hangs on me. The working databases seem fine (at least the websites are online). When I tried to access the bad database websites, it will just keep spinning.

If I do a:

mysql> use rbb;
mysql> SELECT * FROM wp_posts;

It will just hang.

My server is running CentOS 6.2 and up to now i've had no issues.

Any pointers would be much appreciated. I have no idea what to do next.

Even opening a Sequel Pro to the server hangs the application.

If I try a query and then check the process list in another connection, it shows:

| Id | User | Host      | db  | Command | Time | State          | Info                   |
| 10 | root | localhost | rbb | Query   | 45   | Opening tables | SELECT * FROM wp_users |

MySQL Version is 5.5.28-log:

mysql> SELECT @@version;
| @@version  |
| 5.5.28-log |
1 row in set (0.00 sec)

I was experimenting about a year ago with ClouSE, but haven't used this since. My error log does report this, however.

131207 20:49:38 [ERROR] ClouSE: S3 listObjects for 'hondurasproject' failed. SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed.

I have tried a few times to restart the server, but it hasn't helped.

Server disk space is looking good. 66G is available. Output below:

[root@server log]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/xvda1             91G   21G   66G  24% /
tmpfs                 1.9G     0  1.9G   0% /dev/shm
  • I'm doing a bit of contemplating on the overall issue, but can tell now you that many GUI tools do some startup discovery by polling information_schema, including some extremely silly things like SELECT DISTINCT column_name FROM information_schema.columns... so Sequel Pro locking things up isn't surprising, in this situation... troubleshooting bad behavior is safest done with the mysql CLI, as you are doing. Dec 7, 2013 at 22:20
  • 1
    SELECT @@log_error; will give the location of the MySQL error log; check that file for recent entries, please. SELECT @@version; and mention that in your post. How is your free disk space? Have you stopped and restarted the mysql server process (I'm not saying do that; please don't, yet, if you haven't, because it might make the problem temporarily disappear, only to resurface). Is there anything recent/interesting in /var/log/messages? Dec 7, 2013 at 22:31
  • I've updated post with MySQL version (5.5.28-log) and error log. I had previously tried a MySQL restart as well as a full server restart. This hasn't helped. Pretty weird... If I could only salvage the data then I could get another server created and use it. Dec 7, 2013 at 23:54
  • As for diskspace, it is looking good. 66G available. Dec 7, 2013 at 23:56

1 Answer 1


Yes, WordPress uses the default storage engine (which is InnoDB since MySQL 5.5).

I'm not sure I understand the problem. Can you execute the SELECT using the mysql command client? If you can, the problem is in the GUIs you use.

If you cannot (which means that you will receive an error, I think) you should investigate the error log. The only possible problem I can think now is a damaged table (REPAIR TABLE should solve the problem), but the error log should give you the exact answer.

  • I've just tried a repair table and the response says Corrupt. Can I retrieve any data? Or is it now completely gone? Dec 8, 2013 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.