1

I recently updated my server's database system from MySQL to MariaDB. After update, everything works well.

But, when I went to phpMyAdmin, the default charset and types are changed:

MySQL chareset and type info

At the end of this image, the default type was set to 'InnoDB' and charset was set to 'latin1_swedish_ci'. They were 'MyISAM' and 'utf8_general_ci' before. How can I revert my character set and type settings back, and how can I customize settings when I make new database?

When I looked at /etc/my.cnf and /etc/my.cnf.rpmnew, I couldn't find any settings related to DB type/charset.

0

"How can I revert my character set" :

ALTER TABLE myTable CONVERT TO CHARACTER SET "utf8";

"How can I revert my type": (MySQL Engine):

ALTER TABLE myTbale ENGINE=MyISAM;

"how can I customize settings when I make new database?"

In your my.cnf

default-storage-engine=MyISAM

Best Regards.

Max.

0
  • You can change server's charset and collation by editing my.cnf file and restart MySQL server to have effect

http://dev.mysql.com/doc/refman/5.6/en/charset-server.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.