0

I hope that you help me to resolve my problem. I'm trying to install Oracle 11g on RHEL 6. All prerequisites are ok, but I'm getting such error during step "Creating and starting Oracle instance". The error text is ORA-00443: background process "DIAG" did not start

Sometimes installation fails on 8%, sometimes on 44%. It's very strange. I thought it's related to RAM but I have enough memory (10Gb).

I tried to retry installation several times and sometimes it shows me that another background process (not DIAG, but RDBM for example) did not start. It seems that second part of error is random. But the error code ORA-00443 remains the same.

Here are some information from logs which says nothing to me where is the root cause of a problem

[Thread-10] [ 2013-12-17 23:04:34.027 EET ] [CloneDBCreationStep.executeImpl:460]  calling zerodbid
[Thread-10] [ 2013-12-17 23:04:41.620 EET ] [CloneDBCreationStep.executeImpl:470]  Shutdown database
[Thread-10] [ 2013-12-17 23:04:41.622 EET ] [CloneDBCreationStep.executeImpl:492]  Startup ......nomount......
[Thread-14] [ 2013-12-17 23:07:03.433 EET ] [BasicStep.handleNonIgnorableError:430]  oracle.sysman.assistants.util.UIMessageHandler@1719f30:messageHandler
[Thread-14] [ 2013-12-17 23:07:03.433 EET ] [BasicStep.handleNonIgnorableError:431]  ORA-00443: background process "DIAG" did not start

I tried to find solution within all possible resources, but no luck. Please help to resolve issue. Thanks in advance.

migrated from stackoverflow.com Dec 17 '13 at 22:22

This question came from our site for professional and enthusiast programmers.

  • 1
    Is there an alert log, or any trace files for the failing processes? – Alex Poole Dec 17 '13 at 23:12
  • 2
    I think alert log (alert_<SID>.log) should be already created so look there. Also as a wild guess - try disabling SELinux. – Mindaugas Riauba Dec 18 '13 at 5:44
  • Are there any more errors after the ORA-00433? – Andrew Brennan Jun 16 '14 at 17:06
  • Please login on the same user as you tried install (it was oracle, wasn't it?) and update the question with ulimit -a. – kubanczyk Jul 17 '14 at 15:29
-1

Your OS is x86 but not amd64? It seems SGA setting larger than system limit. Set your oracle memory under 2GB.

  • 2
    10Gb RAM... I hope the OP is running a 64-bit OS. – Colin 't Hart May 16 '14 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy