We are installing SQL Server 2012 on Windows Server 2012 and trying to accomplish clustering.

We've setup all the core functionality on the servers: advanced cluster preparation on all nodes and then completion on the final node. However, when we get to completion phase it completes and at the end it throws an error.

Here are the error details:

Feature: Data Quality Services
Status: Failed: see logs for details
Reason for failure: An error occurred for a dependency of the feature causing the setup process for the feature to fail.
Next Step: Use the following information to resolve the error, run RemoveNode on all the nodes of this instance, and then run PrepareFailoverCluster and then run CompleteFailoverCluster process again.
Component name: SQL Server Database Engine Services Instance Features
Component error code: 0x80131577
Error description: The given key was not present in the dictionary.

I've tried rebuilding the system a few times and tried running the commands it referrers to with no avail. I feel like it's something simple that I'm just missing, any ideas anyone?

  • Have you tried downloading the setup files again? Perhaps the source files are corrupted.
    – Hannah Vernon
    Jan 3, 2014 at 16:05
  • Are pulling updates in the install as well? If not, then you should probably just get the new SP1 media to install. See: blogs.msdn.com/b/dqs/archive/2012/06/25/…
    – swasheck
    Jan 3, 2014 at 16:17
  • It seems either the Service Pack (CU1), does not install as part of the updates and this can cause an error. I’m going to Remove SQL from both nodes and then Patch both nodes and see if that remedies the error.
    – amcdnl
    Jan 3, 2014 at 18:33
  • What is the domain functional level and forest functional level of the Active Directory domain?
    – mrdenny
    Jan 14, 2014 at 9:02

1 Answer 1


Install with the pre-SP1 SQL 2012 media. Then, after your cluster is up, follow the procedure to apply SP1. It appears the 11/2012 SP1 slipstream installer was not tested for this component when being installed from scratch.

This media worked: en_sql_server_2012_enterprise_edition_x86_x64_dvd_813294.iso

This did not: SQLServer2012SP1-FullSlipstream-ENU-x64.iso

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.