1

I'm using the CREATE USER and GRANT commands as mentioned here http://dev.n0ise.net/2012/09/amazon-rds-mysql-add-additional-users-with-limited-previledges/

When I try to connect I get this in MySQL Quer Browser:

Could not connect to host '...sa-east-1.rds.amazonaws.com'.
MySQL Error Nr. 0

Output in MySQL Workbench:

Your connection attempt failed for user 'site' from your host to server at ...sa-east-1.rds.amazonaws.com:3306:
  MySQL server has gone away

Some details:

  • MySQL version: 5.6.13

  • Credentials are typed correctly. When I miss them I get the standard 1045 access denied error.

  • The user created with the instance and another limited user I created some weeks ago are working fine

  • Same commands worked fine on a non RDS server

Any ideas?

Thanks in advance.

2
  • Did you run FLUSH PRIVILEGES; after granting?
    – Philᵀᴹ
    Jan 7, 2014 at 17:24
  • Yes. I also tried to restart the instance.
    – FkJ
    Jan 7, 2014 at 17:30

1 Answer 1

2

I forgot that I had created a stored procedure to set the time zone after every connection made.

Looking at the server log I found that the problem was that the new users didn't have permission to execute it.

1
  • Thank you, this is a wonderful tip for something to be aware of.
    – dotancohen
    Mar 20, 2014 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.