0

I installed Oracle 11g R2 PS4 on SunOS 5.10 sparc machine.

When i try to create a new database using the Database Creation Assistant tool (dbca) i get the popup message ORA-12560: TNS:protocol adapter error with no more explanations.
So i tried to create my database using the commandline but i got the same error :

SQL> startup nomount pfile="/opt/oracle/admin/TRIO/scripts/init.ora";
ORA-12560: TNS:protocol adapter error

I verified that the variables ORACLE_HOME, ORACLE_SID, ORACLE_BASE are all correctly set.

  • What's in the DBCA log and the alert log of the partially created database? Have you previously successfully created a database on this machine? – Philᵀᴹ Jan 10 '14 at 0:15
  • No alert file was generated since the instance was not created. No DBCA log generated also. – Slyx Jan 10 '14 at 1:57
  • Go through the Oracle for Solaris install doc and double check you've met all of the prerequisites: docs.oracle.com/cd/E11882_01/install.112/e24346/pre_install.htm - pay particular attention to the kernel params, shell limits and required packages. Go through the entire thing from the start carefully, you may have missed something (assuming you read it in the first place) – Philᵀᴹ Jan 10 '14 at 2:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.